1

I have a wordpress 4.7.6 without plugins, however, I've noticed this: https://cxsecurity.com/cveshow/CVE-2017-14723 And the other vulnerabilities that are <4.8.2.

My question is, I have tried to search how to exploit it in my wordpress, but I do not find how. I appreciate your help and well, I am assuming that if it is <4.8.2, it is vulnerable, right?

closed as off-topic by Mirsad, Xander, Steffen Ullrich, schroeder Oct 27 '17 at 10:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions asking us to break the security of a specific system for you are off-topic unless they demonstrate an understanding of the concepts involved and clearly identify a specific problem." – Mirsad, Xander, Steffen Ullrich, schroeder
If this question can be reworded to fit the rules in the help center, please edit the question.

2

If you check here you will see that WordPress versions 4.8.1 and earlier are affected by nine security issues:

  1. $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi). WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability. Reported by Slavco.
  2. A cross-site scripting (XSS) vulnerability was discovered in the oEmbed discovery. Reported by xknown of the WordPress Security Team.
  3. A cross-site scripting (XSS) vulnerability was discovered in the visual editor. Reported by Rodolfo Assis (@brutelogic) of Sucuri Security.
  4. A path traversal vulnerability was discovered in the file unzipping code. Reported by Alex Chapman (noxrnet).
  5. A cross-site scripting (XSS) vulnerability was discovered in the plugin editor. Reported by 陈瑞琦 (Chen Ruiqi).
  6. An open redirect was discovered on the user and term edit screens. Reported by Yasin Soliman (ysx).
  7. A path traversal vulnerability was discovered in the customizer. Reported by Weston Ruter of the WordPress Security Team.
  8. A cross-site scripting (XSS) vulnerability was discovered in template names. Reported by Luka (sikic).
  9. A cross-site scripting (XSS) vulnerability was discovered in the link modal. Reported by Anas Roubi (qasuar).

So yes, you should updated your Wordpress to the latest one.

  • Exactly, I have reviewed that, but I would like to exploit them, say, know how the xss is done in my reflected wordpress 4.7.6 and I have searched all the information for it and do not give PoC how to do it ... @Mirsad – caperiwazo Oct 26 '17 at 21:46
  • Or for example, in which attack vector is that SQL injection – caperiwazo Oct 26 '17 at 21:47
  • How can I be sure that you will not use that against someone else? – Mirsad Oct 26 '17 at 21:55
  • I have my wordpress in my localhost, I just want to learn. If I really wanted to use that against someone, I would not be around ... – caperiwazo Oct 26 '17 at 21:57
  • If you realy want to learn, than learn to understand how vulnerable code works from coding perspective - if you come here and ask: "can you find me an exploit for this or that..." - how is that learning? – Mirsad Oct 26 '17 at 22:03
0

Because CVE-2017-14723 affects the framework, it enables the possibility for a SQLi attack in themes and plug-ins. There is not a direct PoC, as it would depend on the implementation.

A little more digging, and I found this: https://vuldb.com/?id.107044

There are known technical details, but no exploit is available.

Not the answer you're looking for? Browse other questions tagged or ask your own question.