I'm brand new to the field of pen testing, so please excuse my ignorance and the potential asking of a question that already exists. As I stated in the title, there are times when I run airodump-ng [interface] and no networks are displayed. And to be clear, I do not mean that certain networks show up sometimes and not others; I mean that zero networks are displayed. I am using the Alfa AWUS036NEH network adapter with the Ralink RT2870/RT3070 chipset, and I know of three ways in which to switch this adapter to Monitor mode (excluding code to turn off wireless adapter and turn it back on):

  1. iwconfig wlan0 mode monitor
  2. airmon-ng start wlan0
  3. airmon-ng check kill followed by airmon-ng start wlan0

When I try to use any of these various methods, I get varied results. Sometimes the second approach will work and other times it won't. Same with the other methods.

My question, then, is whether this is normal or not. From what I have found online, the network adapter I am using is not one of the most popular ones, so I'm willing to buy a new one if that's the reason. But knowing that it might just be me not fully understanding how everything works, I was hoping to get some insight from this community.

For what it's worth, I'm using Airbase-ng 1.2 rc4 and running cat /etc/issue shows Kali GNU/Linux Rolling \n \l. Please let me know if more information is needed.

  • This isn't normal. I have the same card as you and I have a script with this card which starts it up in monitor mode on boot (raspberry pi monitoring station). Have you tried just doing ifconfig wlan0 down; ifconfig wlan up before doing any of this?
    – Allison
    Oct 29, 2017 at 1:34
  • I have not. Is the suggestion to then do: ifconfig wlan0 down; ifconfig wlan0 up; ifconfig wlan0 down; iwconfig wlan0 mode monitor; ifconfig wlan0 up?
    – brittenb
    Oct 29, 2017 at 1:36
  • 1
    Yes. Sometimes you just need to... poke... the card first. Some shitty drivers this will cause a kernel panic on though so watch out.
    – Allison
    Oct 29, 2017 at 1:40

2 Answers 2


Try running airmon-ng first followed by airmon-ng check kill. If that does not work try killing the processes manually by typing kill [pid of the process]. And if all that does not work try "rfkill unblock all", this will unblock your adapter if it was being blocked by the firmware as it is not a very famous adapter and may not have the proper drivers installed.

Try all of the above methods and if all of them fail then your adapter may not be compatible or may partially be compatible, i suggest getting a TP-Link WN722N v-1.0. It is a budget adapter and i personally use it besides alfa adapters. Make sure you get the v-1.0 because v-2.0 is not compatible.

  • Welcome on the Security SE! Note, all capital nicks don't look very well, I suggest to become simply "The Yogovo".
    – peterh
    Aug 19, 2018 at 6:26

I would suggest using Kali 2018.2. I could not find anything with a clear solution, but the RT2870/RT3070 chipset appeared not to be compatible with the Linux kernel a year ago, and only had closed source drivers. Kali Linux 2.0 Compatible USB Adapter Test and issue with RT3070 chipset may give perspective.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .