-2

When I am trying to upload a file, download a file or enter a folder, metasploit does not work. Path of metasploit is in meterpreter.

meterpreter>
upload /root/Desktop/test.exe C:\\Documents and Settings\\PC_1\\Escritorio
[*] uploading  : /root/Desktop/test.exe -> Settings\PC_1\Escritorio
[-] core_channel_open: Operation failed: The system cannot find the path specified.

download C:\\Documents and Settings\\PC_1\\Escritorio\\topsecret.txt
[-] stdapi_fs_stat: Operation failed: The system cannot find the file specified.

cd C:\Documents and Settings\PC_1\Escritorio
[-] stdapi_fs_chdir: Operation failed: The system cannot find the file specified.
  • I believe that you may need to put the target location in quotation marks, due to the spacing in file naming, i.e. "C:\\Documents and Settings\\PC_1\\Escritorio" – vakus Nov 8 '17 at 22:26
1

Take a look at the Metasploit commands glossary.

As the example shows, you need to use double back slashes, not just one.

meterpreter > upload evil_trojan.exe c:\\windows\\system32

This is also stated in the download command:

Note the use of the double-slashes when giving the Windows path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.