1

I noticed some images only will be loaded if they are before cached.

That is, if I open the browser it won't load directly. But if I first load the image individually on the browser and later I open the site then it will load. This happens for every page saved in my pc.

Here is a gif. I hope it explain better:

Any risk if I keep using Tor Browser?

  • Can you reproduce that with images on the web or just locally? – Arminius Nov 26 '17 at 22:40
  • External images works normally. This is only happening locally. I tried it with the image in the same folder or different folder. Also I tried to load it using javascript/jquery. In all ocasions I got the same problem. – wsz12461 Nov 27 '17 at 3:26
2

That is not a bug.

This is part of a temporary fix for an IP leak vulnerability discovered in Firefox related to its file:// handling. See the blog post and the bug on the bug tracker. The behavior was added in 7.0.9 and will likely be changed to a more complete fix when the vulnerability is made public. Until then, the behavior you are seeing is a stop-gap measure to protect from IP leaks.

This temporary mitigation works by blocking embedded resources in resources loaded from your filesystem, while still permitting loading a resource directly. In fact, their temporary solution for the inability to click links is to load the link directly. This is what you are seeing. An embedded image does not load, but when it is opened directly by itself, it displays fine.

  • 1
    Thank you for awnser. So, from my understanding it's just in Firefox/Tor Browser. Maybe this have a relation with uBlock Origin is not working on this version... – wsz12461 Nov 27 '17 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.