0

Here is the issue I can't resolve. Remote RDP server presents a self-signed certificate, and I want to block any connection on client-side when RDP server is using non compliant certificate.

I found a configuration that should enforce server authentication, but it is only blocking when server name in RDP client does not match server certificate CN (for exemple, if i try to connect using IP instead of host).

I can't find any local configuration (GPO, local strategy...) so block RDP connection when server is using a self-signed certificate.

(I am not looking for configuring a compliant certificate on server side, because anyway, my client is configured to accept any certificate that has the server name is the certifcate CN field).

  • Did you just answer your question? In last sentence you said "my client is configured to accept any certificate that has the server name in the certificate CN field". As you say, whatever self-signed cert is accepted or not, is on client-side, so you should look over there. – Aria Jan 2 '18 at 15:07
  • @Aria In fact, despite I enabled "RDP server authentication" on local client side (in local workstation strategy), problem is still here... It seems that my client only validates that RDP server hostname = Certificate CN, but I don't know how to enable certificate path validation (it should be by default...) – crypto-learner Jan 2 '18 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.