2

I am installing Ubuntu 16.04.3 on a desktop. When I get to the step where I am prompted for a hostname, I randomly type in "fortknox" but the Ubuntu installation says "That name already exists on the network."

Here is some background that may be relevant. My fiber connection to the Internet was installed by AT&T a few days ago. The modem is an Arris BGW210-700. All of my computers are behind the router's firewall and are assigned IPs by the router's dhcp such as 192.168.1.84 and so on. I confirmed the IP address 192.168.1.84 was assigned to the new Ubuntu box by looking at the modem's HTTP device webpage.

The router/modem is located in another room. I am using a USB wifi dongle to connect to the router on the Ubuntu box. When I got the message saying the hostname "fortknox" already exists on the network, I went to another Linux box and did 'ping fortknox' and got a response back from IP 104.239.207.44.

Did an ARIN lookup (https://whois.arin.net/rest/net/NET-104-239-128-0-1/pft?s=104.239.207.44) and found that the IP address is owned by a big datacenter here in town named Rackspace. This raises a number of questions for me.

Is my wifi dongle on my new Ubuntu box getting spoofed? Since I am able to confirm the IP was assigned by the ATT router/modem, I don't think so.

Is my new Ubuntu box visible from the Internet?

I don't have in-depth understanding of networking protocols but it seems very suspicious that my new Ubuntu installation inside of my home network can't use a hostname on an entirely different network.

1

The way hostnames work in GNU/Linux is kinda silly. The system itself only knows of the hostname, not the fully qualified domain name (FQDN). In your example, your hostname is 'fortknox'. To get the FQDN, for example, if you run the 'hostname -f' command, what happens is it uses the resolve to resolve the address of your hostname, then uses the resolver to get the reverse of that to translate the address back into a domain name. Since you don't have your hostname in your '/etc/hosts' file, it is using DNS and looking at /etc/resolv.conf. It will search any 'domain' or 'search' listings in '/etc/resolv.conf' until it finds an address that matches that name. For example, if you had "search example.com" and "fortknox.example.com" matched an address "256.0.0.1", it would then go on to reverse lookup that address and find "fortknox.example.com" or it may even find another FQDN that has nothing to do with either "fortnox" or "example.com".

In order to solve your problem, there are a few options. Most people just add their hostname to their "/etc/hosts" file so that it resolves to "::1" or "127.0.0.1". Another thing you can do is edit your "/etc/resolv.conf" and take out the "domain" and "search" entries that you don't want to be searching. Since you are getting this error during install of the operating system, you are probably getting your "domain" and "search" from your DHCP server. In that case, you can edit those settings on your DHCP server. If you don't have access to the DHCP server, the easiest thing you can do it just choose a different name.

  • Jacob, thanks for providing an answer. It really isn't a problem for me to use another hostname. What I am asking is if this could be a router or network configuration problem as the router was just installed. The guy doing the install seemed a little lost at times and asked that I call him first instead of calling AT&T tech support. My expectation is that the router would treat hosts on my home network as its own network domain. Doesn't the fact that my hostname choice ("fortknox") is colliding with a hostname on the Internet point to a router configuration problem? – user104531 Jan 11 '18 at 17:43
  • I wouldn't say that it's a configuration problem with the router, but if you really wanted to use that hostname, and the router is acting as your DHCP server (which it most likely is), then you could fix this by modifying the DNS settings of your DHCP server on the router. Alternatively, you could just change your DHCP settings on your client to ignore the DNS settings, and use a hard coded DNS server (I like 8.8.8.8 mostly because it is easy to remember.). Most modern Operating systems in the last decade or two will let you override the DNS settings of DHCP like that. – Jacob Brown Jan 14 '18 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.