4

Background

When I run Metasploit, it hangs at the same place no matter what I do. It stops at this line,

[*] Using code '404' as not found.

Steps to reproduce,

msf > mfsconsole
msf > load wmap
msf > wmap_sites -l
msf > wmap_targets -t http://123.12.123.123/index.php
msf > wmap_run -t
msf > wmap_run -e

At this point it runs and then gets stuck here,

[*] Using code '404' as not found.

I have tried this on MacOS High Sierra & Kali Linux.

Both fail in the exact same place.

What is the cause of this and how do I overcome it?

  • 2
    The only way i was able to get past this so far was to change the module auxiliary/scanner/http/brute_dirs.rb to auxiliary/scanner/http/brute_dirs.rb.bak to remove it from being ran during the scan. – rubio Feb 11 '18 at 23:10
1

I had the same issue. My resolution was to reload the modules.

You can do that with the following command:

wmap_modules -r

| improve this answer | |
0

Get out of metasploit, and run:

mv /usr/share/metasploit-framework/modules/auxiliary/scanner/http/brute_dirs.rb /usr/share/metasploit-framework/modules/auxiliary/scanner/http/brute_dirs.rb.bak 

This worked for me and is based on the comment of @rubio above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.