2

I'm having a weird bug. I've tried this result on two different VM's on the latest Metasploit version.

msf exploit(windows/smb/ms08_067_netapi) > show options

Module options (exploit/windows/smb/ms08_067_netapi):

   Name     Current Setting  Required  Description
   ----     ---------------  --------  -----------
   RHOST                     yes       The target address
   RPORT    445              yes       The SMB service port (TCP)
   SMBPIPE  BROWSER          yes       The pipe name to use (BROWSER, SRVSVC)


Payload options (windows/meterpreter/bind_tcp):

   Name      Current Setting  Required  Description
   ----      ---------------  --------  -----------
   EXITFUNC  thread           yes       Exit technique (Accepted: '', seh, thread, process, none)
   LPORT     4444             yes       The listen port
   RHOST                      no        The target address

For some reason, the payload only gives me the RHOST option so I cannot set the LHOST. I've tried setting it anyway but I cannot set it.

  • Please read the documentation. – schroeder Mar 24 '18 at 9:05
  • Why do you want to set LHOST? – schroeder Mar 24 '18 at 9:07
3

A bind_tcp payload doesn't require a LHOST because it doesn't initially make an outgoing connection. Instead, it listens (binds) to the specified port.

Perhaps you are wanting to use a reverse_tcp payload, this would require a LHOST and LPORT to be specified to connect to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.