I went to log on to https://mail.google.com this morning and I got the following error. Is someone trying to attack me or is this just a bug?

I'm on a WPA2 encrypted wireless connection using Chrome Canary 22.0.1230.0. I've tried clearing my browser's private data and restarting Chrome. Gmail appears to be working in Safari and Firefox, but I haven't tried logging in.

Incorrect certificate for host.

The server presented a certificate that doesn't match built-in expectations.
These expectations are included for certain, high-security websites in order to protect you.
Error 150 (net::ERR_SSL_PINNED_KEY_NOT_IN_CERT_CHAIN): The server's certificate appears to be a forgery.

  • 3
    Is this a private network or a corporate one? Are you going through a web proxy?
    – GdD
    Aug 8, 2012 at 14:03
  • Yep. (yep was at the other guys answer - not you being hacked.) I'm going to blame Canary. Just updated mine and am now getting the same error. Looks like it's back to beta for a while. :D Aug 8, 2012 at 14:12
  • 3
    please post the certificate
    – user11101
    Aug 8, 2012 at 14:32
  • 1
    If you Register using the same email address you used to ask the question, you will then be able to post comments. (if I understand the system right) That way you can respond to what we say if you like, that would be preferable over suggesting edits to the answers. :) Aug 8, 2012 at 18:15
  • I'm having some troubles with StackExchange. For some reason it let me sign up with the same email twice, yet the accounts are still not linked. @GeorgeBailey, I clicked the edit button, but I didn't submit anything, not sure why it still said I tried to edit your stuff. I tried a non Canary version of Chrome and it works fine. Thanks for the info!
    – Ben Hohner
    Aug 8, 2012 at 18:34

1 Answer 1


Try it on a non-Canary build of Chrome. Last I checked, Canary builds aren't even tested before release so you can't come to any any concrete conclusions unless you use one of the release branches.

As for making the same https connection using Firefox and Safari, I think you have disproved covered the vast majority of security failure possibilities. But the error from Chrome is from a feature that Firefox and Safari do not provide. Thus a good final step would be to get the Chrome stable version to answer your question.

Since Canary builds are so volatile, I think that getting a yes or no answer from us to whether it is a bug is unlikely, unless someone else who runs Canary happened to re-create the problem. You need to use one of the release branches of Chrome.

Edit: According to other comments posted on your question (which have since been deleted), it looks like a temporary Canary problem, switching off of Canary will most likely fix it, and, if you are on an untrusted WiFi, that would be a safer than ignoring the error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .