2

Why do google sites display content in my original country's language even if i'm connected to the internet through a VPN?

For exapmple: google.com and youtube displays content in my actual language, maps.google initiates near my hometown. Browsing msn.com though, redirects to the VPN's country.

I setup a VPN (unblockr.net) connection on my computer that is running an Ubuntu operating system. I am also using firefox. I have tested if my ip changes and it does, so the VPN works but not on google.

Is there some information saved on my system that google can access ? I removed all cookies,history,bookmarks and reinstalled firefox and even changed my date and time settings on my desktop.

  • Does that still happen if you switch to a fresh browser profile? (Or use incognito mode?) – Arminius Apr 7 '18 at 11:24
  • Check preferred languages in your browser settings, most likely your browser is telling the website that you prefer your native language. – Teun Vink Apr 7 '18 at 11:43
  • Yes , it still happens with a new browser profile and incognito mode. And my preferred language is set by default to eng-us which is not the problem. – Coze Apr 7 '18 at 11:57
  • Did you login to google? – nbering Apr 7 '18 at 14:06
  • Is IPv6 disabled or routed through the VPN? – Nomad Apr 7 '18 at 16:21
3

My best guess is IPv6 isn't configured on the VPN and because Google is one of the few companies that actively use it, you don't notice the same behavior with other sites.

Disable ipv6 on your outgoing ethernet/wifi adapter and it should be fine.

DNS

To push your DNS from the server to your client, leave the client-config the way it is and add this to your /etc/openvpn/server.conf:

# server.conf 
push "dhcp-option DNS x.x.x.x"
push "block-outside-dns"
  • I disabled IPv6 and finally websites load at the VPN's country. Google maps also load at a random location. Before disabling IPv6 i reinstalled ubuntu 16.04 and then i followed all of the above instructions but i didnt disable geoclue and GeoIP. So my question about google is answered. But a DNS leak at dnsleaktest.com still occurs. All the dns servers originate from my ISP. – Coze Apr 16 '18 at 12:37
  • Do you have dhcp-option DNS x.x.x.x and dhcp-option DOMAIN X.Y set in your client.ovpn? – Nomad Apr 16 '18 at 13:07
  • The ovpn file i imported cointains: client, nobind, dev tun, proto udp, remove-cert-tls server, remote-random, resolv-retry infinite, key-direction 1, redirect-gateway def1, block-outside-dns. After that it cointains some keys and certificates. I didnt find anything related with dhcp or what you mentioned. Am i searching at the wrong place? Mabye i should manualy change the dns servers to opendns ones? – Coze Apr 16 '18 at 13:27
  • Added something to the answer, give that a try and test again! – Nomad Apr 16 '18 at 19:13
  • The only file at /etc/openvpn/ is update-resolv-conf instead of server.conf. So should i replace # server.conf with # update-resolv-conf ? And do ṕush arguments take quotes " " ? Im very thankfull for help but i dont want to bother anymore with newb questions. – Coze Apr 17 '18 at 10:52
6

I strongly suspect that the VPN is working but you're leaking information in another way. Some things to try are:

  • Turn off location services on your computer
  • Use incognito mode
  • Disable all browser extensions in incognito mode (I think this isn't the default in Firefox)
  • Make sure you're not leaking data via WebRTC
  • Don't login to Google (or any other sites)
  • Flush your DNS cache in case you are pointing to a region-specific IP address of Google

If this still doesn't work, visit browser fingerprinting sites such as Panopticlick to see if they provide you with any hints.

Update: Perhaps Google is not actually detecting your location, but is instead getting an Accept-Language header from your browser. See what happens if you do the above and set your browser's language preference to English.

  • Thanks for your reply , i hope this will solve my problem. I will try those things out in a few hours and give you an update. – Coze Apr 8 '18 at 19:56
  • Hello again, i tried everything you suggested. Removed geoip and geoclue from ubuntu then disabled WebRTC at about:config (firefox) , flushed dns cache. And ofcourse im not logged into google, im using incognito mode and i have no extensions on my browser. But my ip is still leaking. So i guess i have done something wrong . Should still mark your answer tho? You were helpfull and i appreciate it. – Coze Apr 13 '18 at 15:45
  • @Coze - I appreciate it, but I wouldn't mark this as the answer if it didn't solve your problems. Marking it might be confusing to future readers. But once you have 15 rep, you can vote up answers that you think were helpful, even if they didn't get it all correct. But thanks for asking! – Neil Smithline Apr 13 '18 at 16:36
  • @Coze - I had another thought. See the edited answer. – Neil Smithline Apr 13 '18 at 16:40
  • OP has specified that their browser is set to prefer English. security.stackexchange.com/questions/183155/… – a CVn Apr 13 '18 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.