3

We have an application that is running Doctrine1 and it would be a VERY large undertaking to upgrade from Doctrine1 to the current Doctrine3 (essentially a complete rewrite).

From a security standpoint, what is the risk with using this library?

1
  • 1
    Did you do a Google search for what vulnerabilities exist in Doctrine1 and the version of PHP you are using? Commented Apr 17, 2018 at 16:27

1 Answer 1

4

Any time you are using a library that has not and cannot be updated, you are increasing your exposure to risks of vulnerabilities in that library (and in other libraries embedded into that library). This talk by Kymberlee Price does a nice job of talking through some of the impact a third-party library or integration of any kind can have on your codebase's attack surface and risk profile.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .