2

How can I identify whether the remote server is vulnerable to TLS POODLE vulnerability? Although, there are online scanners such as Qualys SSL Labs. As per my understanding, these online scanners do not work on custom ports such as 8086, 8909 etc. Also, these scanners cannot be used when we are performing the security assessment on internal network devices.

3 Answers 3

1

Poodle attack works on SSLv3 although there is a variant of poodle attack on TLS that appeared in recent years by accepting incorrect padding after decryption.

nmap is checking the TLS/SSL version. You can find the script of poodle identification rules online.

It is recommended to completely disable SSLv3 on server side. On the client side, you should always upgrade to the latest version. Also, most of the browsers/servers use "TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade Attacks" to prevent any intentional downgrade of version and drop the connection.

0

I personally like https://testssl.sh/, will check a lot of things and is just one script that manages all issues. If you have a look to the documentation (https://github.com/drwetter/testssl.sh/blob/3.1dev/doc/testssl.1.md) on the section "Basic parameters" you can find a full description of how to manage the ports.

1
  • While I personally use this script as well, please expand your answer a little. For example, how to scan custom ports (which is what OP asked for), or how the output looks like for poodle. For example, the -O option only scans for POODLE.
    – user163495
    Feb 10, 2020 at 10:51
-2

You can use nmap:

nmap -sV --version-light --script ssl-poodle -p 8086 example.org
4
  • My understanding says that this script will not identify TLS POODLE.
    – Shiv Sahni
    Apr 28, 2018 at 7:34
  • 1
    @ShivSahni why do you think that? Apr 28, 2018 at 7:36
  • 2
    Rather than posting a one-liner, please explain what it does. It's not very useful to people who have not used nmap before, and blindly copying commands off the internet without understanding them is a bad idea.
    – forest
    Apr 28, 2018 at 11:15
  • Checking whether it is vulnerable on port 8086(-p 8086). Jun 24, 2018 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .