2

We have been using OpenVas to scan our servers for months now. Recently the scans are getting stuck on different %, always below 30%. We did not change anything in my local configuration. I read a post somewhere that I should lower the maximum concurrently executed NVTs per host to 4 and maximum concurrently scanned hosts to 5.

Does anybody have other suggestions of what setting should we check?

Could it be firewall or something blocking the scan so it times out?

Any suggestions would be greatly appreciated.

  • Do you know if a specific machine causes it? In order to check you can either create scans with fewer machines and see where the issue persists. Another option to check it is to change the scan order to randomized or reversed. This can be done on non-alterable scans as well. – Uberhumus May 2 '18 at 17:34
  • Could you share the version information of the OpenVAS components you're using? – cfischer May 9 '18 at 16:53
1

Thanks for the recommendations. I ended up reinstalling everything from scratch. Also applied Uberhumus suggestion of setting scan order to random.

Other settings I applied:

  1. Maximum concurrently executed NVTs per host = 4.
  2. Maximum concurrently scanned hosts = 5.
  3. I created targets with about 50 hosts per scan.
  4. Disabled the "automatic suspend" in power options.

By doing this I was able to complete the scans.

Hope this helps anybody facing the same issue.

  • 1
    You do not state that these actions helped to solve the problem. Did they? – schroeder May 10 '18 at 13:32
  • So far the scans are running. I also disabled the "automatic suspend" in power options. – lro985 May 11 '18 at 20:35
  • Please edit your answer to include these details – schroeder May 11 '18 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.