0

I am using VMware and have 3 VMs all on the NAT network with DHCP. All three machines can ping each other. From one windows to the other windows, I can RDP into the 192.168.190.130 windows machine just fine.

I want to confirm that hydra works, so back on my Kali VM, I try the following command hydra -t 1 -V -f -l username -p password1! rdp://192.168.190.130. After hitting enter I get two [DATA] messages, 1 [ATTEMPT], and then it pauses for a long time and prints [STATUS] messages to the screen for example: [STATUS] 1.00 tries/min, 1 tries in 00:00h, 0 to do in 01:00h, 1 active

I am looking for the indication that there was a successful attack, but I never see it.

When I open up wireshark and view the traffic, I see TCP traffic on 3389 port happening back and forth, but it never returns with a successful notification.

  • On that note, the VM that is being attacked, does have it's screen locked as if someone logged in. Hydra simply does not display that the attack worked and you should use that username and password – Matthew May 23 '18 at 16:27
0

If no firewall is blocking packets between Kali Linux and the Windows Box, Hydra should be able to successfully notify that the provided credentials worked

root@kali:~# hydra -t 1 -l username -p password1! rdp://192.168.190.130

Hydra v8.3 (c) 2016 by van Hauser/THC - Please do not use in military or secret service organizations, or for illegal purposes.

Hydra (http://www.thc.org/thc-hydra) starting at 2018-05-24 11:05:56

[DATA] max 1 task per 1 server, overall 64 tasks, 1 login try (l:1/p:1), ~0 tries per task

[DATA] attacking service rdp on port 3389

[3389][rdp] host: 192.168.190.130 login: username password: password1!

1 of 1 target successfully completed, 1 valid password found

Hydra (http://www.thc.org/thc-hydra) finished at 2018-05-24 11:06:00

  • There is no firewall that I am aware of. I am able to remote into the target machine from a third machine. When I am logged into the target machine, then launch the attack from Kali, it actually locks the screen (as if it were a successful attack) but back on the Kali screen there is still no message of success. I've launched attacks on Windows 7, Windows Server 2008 and Windows Server 2012. All the same issue. I am using a 32 bit version of kali linux though. I don't know if that has anything to do with it – Matthew May 24 '18 at 13:40
  • Just tested it with the 64 bit version of Kali and the same thing is happening. – Matthew May 24 '18 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.