5

When I enable Burpsuite's Proxy I continiously get http GET requests for firefox's detectportal as seen in the following image:

Image showing a capture for a request to firefox's detect portal in burpsuite

How I can configure it to somehow just pass though theese requests silently and just load the target url?

I tried theese settings on Proxy's "options" tab with no desired result (just passing though the firefox's detectportal):

Settings in burp suite for intercepting requests in burpsuite

1
  • 2
    We recommend you turn off captive portal within Firefox. In the future we may add a feature to Burp to ignore requests like these. – PortSwigger Jun 4 '18 at 9:28
5

Disable Captive portal from firefox as seen in this link.

In order to do that open a new tab and type about:config, then search for network.captive-portal-service.enabled and set it as false then you are good to go.

3

When you get a request in BurpSuite that you don't want to intercept again, click the "Action" button, followed by "Do not intercept...", and choose "requests to this host". This should solve the problem without modifying Firefox.

0

FYI, you can filter out the captive portal messages in HTTP history (by regex if you have multiple domains do filter out).

example

0

You can add a wildcard domain to the "TLS Pass Through" settings in Proxy -> Options -> TLS Pass Through. This allows these requests to bypass your proxy which results in a cleaner history

For example add: ^*.firefox.com$

Do note that this will only pass through the HTTPS traffic to these domains.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.