4

To deploy OpenVAS to Virtual machines I've been using Ansible for a while and it worked pretty well. Now today I wanted to deploy it to another machine but the openvas-check-setup script keeps telling me that the setup isn't yet finished because the SCAP database is missing which it in fact is.

ERROR: No OpenVAS SCAP database found. (Tried: /var/lib/openvas/scap-data/scap.db) FIX: Run a SCAP synchronization script like greenbone-scapdata-sync.

The suggested solution doesn't solve the problem. The directory /var/lib/openvas/scap-data does exist and it is by no means empty. The only file that seems to be missing is the scap.db.

To validate the process I moved all the files from /var/lib/openvas/scap-data to a temporary drive and ran greenbone-scapdata-sync again. All the files that had been there before where downloaded again but the SCAP Database is still missing.

2 Answers 2

2

It seems to be the case that an apt-get dist-upgrade caused the trouble. After setting up another VM leaving this step out the installation finished sucessfully.

// Eventhough I got it running I'm now using Ubuntu Server and the packets provided by Mohammad Razavi when it comes to virtualized instances of OpenVAS. I had severe problems handling the scans. The scan processes started but hung themselfes after 1% - 9% and did never finish. Didn't have to deal with problems like this in presvious versions of kali.

1

Check out the greenbone-scapdata-sync --help for some other options that may work; specifically these:

greenbone-scapdata-sync --refresh
greenbone-scapdata-sync --refresh-private

As far as I can tell, they are specifically designed to rebuild scap.db when the other files in /var/lib/openvas/scap-data are present. Worked for me, anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .