2

I have one webapp available on localhost:12345, and another service running on `localhost:6789'. I want to monitor the traffic to/from the webapp (12345), but universally pass the traffic to the service on 6789.

When I run burp and set the scope to localhost:12345 and turn intercept on, it still intercepts traffic on 6789. How can I intercept only the traffic on localhost's port 12345?

  • Won't burp capture both the request and the response? – schroeder Jun 11 '18 at 21:04
  • Yes ... I'm not sure what you're asking or how it needs to be clarified. The traffic to/from the webapp is on 12345, and the service traffic (to/from) is on 6789. – user3.1415927 Jun 11 '18 at 21:34
  • "it still intercepts traffic on 6789." If you are sending traffic from one to the other, then both sides will be captured. Are you saying that there is traffic from 6789 that is not related to 12345? – schroeder Jun 11 '18 at 21:35
  • I'm sending traffic to/from the browser to the webapp for testing, separate from the service that's running on 6789. The two just happen to be occurring simultaneously, and I was hoping to be able to continue normal operations to/from the service on 6789 (I don't have permissions to stop that service). – user3.1415927 Jun 11 '18 at 21:38
  • 1
    In Proxy > Options > Intercept Client Requests, turn on "And URL is in target scope" – PortSwigger Jun 12 '18 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.