0

I've tried so many times with different syntax to display the payload options in msfvenom. However, I cannot get it to run.

Version 1.

[*] exec: msfvenom -p windows/shell/bind_tcp --payload-options

Error: Missing required argument for option
MsfVenom - a Metasploit standalone payload generator.
Also a replacement for msfpayload and msfencode.
Usage: /usr/bin/msfvenom [options] <var=val>

Version 2.

[*] exec: msfvenom -p windows/x64/vncinject/reverse_winhttps -o

Error: Missing required argument for option
MsfVenom - a Metasploit standalone payload generator.
Also a replacement for msfpayload and msfencode.
Usage: /usr/bin/msfvenom [options] <var=val>

How does it exactly work? Have I typed it wrong? Thanks for the help.

1

The syntax for the options have been updated. Use:

./msfvenom -p windows/meterpreter/reverse_tcp --list-options

You can also start msfconsole, select the payload and then use:

show options
show advanced
show evasions

etc to show further detailed options about the payload you have selected.

  • a side note for anyone who might look into this: It will show "permission denied" when you type in the command prompt straght away. However, It works when typing in msfconsole. – Shan Huang Jul 3 '18 at 7:39
  • 1
    @ShanHuang The access denied issue you are facing with msfvenom is due to the OS and the user you are using. For example, if you are using a debian based OS and not using root, you might have to sudo msfvenom. – void_in Jul 3 '18 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.