0

I am testing a bruteforce on a windows rdp server within a domain. It seems to not be working because nothing is locking out the account I am targeting. How do you specify a domain username? I tried username@domain.

hydra -V -f -l username -P '/root/Desktop/linkedin_opt7ic.pot' rdp://targetip

What would be the correct format to attempt this attack?

1

Your syntax looks correct, though you might try adding in the -t flag with a low number (i.e. -t 1) to restrict the number of concurrent connections to 1 as well as the -w flag with a number of seconds (i.e. -w 8) to allow the server you are brute-forcing to be able to recover for 8 seconds before attempting the next try.

Even with these tweaks, however, you may still find no success as it should be known that the RDP module has been found to be unreliable with newer versions of Hydra which is potentially why your efforts aren't fruitful; see this github issue discussion with Hydra [RDP] failing even with correctly supplied credentials.

  • Thank you :) What would be a better alternative that I can use to test rdp bruteforcing on the domain? – john_zombie Aug 9 '18 at 13:30
  • I haven’t tried these for rdp, but Ncrack and crowbar both support rdp brute-forcing. These might be worth checking out – waymobetta Aug 9 '18 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.