0

I configured Tor Hidden Service to forward from port 5400 to 127.0.0.1:1234. Then i restared tor and I got hostname. Now I run nc -l 1234 and i visit the website and I receive a GET request. Now I wanted to send other data so on the other computer I run echo test | torify nc -w 2 -z MY_hidden_service_address port. When I run it my server just quits and does not print test. But if it quits then it means that it receives a response, right?

1

As you can see the connection gets properly open and closed (thats why your nc quits) but there is no data transferred. This is because torify does not expect you to just pipe data into it I suppose. To check maybe try using netcat without torify (nc -v -X5 -x localhost:9050 <server> <port>) or get rid of echo and your pipe and try using nc interactively.

| improve this answer | |
  • I tried this command but it says that parameter -X5 and -x does not exist – Adrian Rudy Dacka Sep 3 '18 at 5:59
  • OK I think i found a problem. Netcat command pointed to ncat not netcat. Now it works. Thanks for help – Adrian Rudy Dacka Sep 3 '18 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.