Recently I had to revoke one of my UIDs and add a new one in my main GPG Key. As I expected the new UID became primary and I tried to change it back to the original one (it's not the revoked one). Strangely I cannot get the primary uid to change. I tried it with --expert on --edit-key but there is no different output.

I select uid 2 and then type primary. After it I save it but there is no change. If I try to redo the steps it tells me after save there has been no change.

Additionally I noticed that my new UID has correct prefferences while all the others are set to minimum. (3DS, SHA1, etc.) When I try to update them with setpref I sometimes get a warning that none of the uids is marked as primary.

Is there something I missed or can do to get a new result?

  • If this were me I would, backup my keyring, export the secret key, delete it and then reimport. If that didn't work I would try again deleting the revoked key before exporting. If that didn't work I would try running gnupg --list-packets on an exported secret key file to see if I could determine what was going on. – William Hay Sep 4 '18 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.