1

I am attempting to get a shell open between a Linux and Windows machine. On the Windows machine, I run:

ncat --exec cmd.exe -vnl 4444 --ssl

Once it is listening, I run the following command on my linux machine:

ncat -v x.x.x.x 4444 --ssl

After doing so, I receive this error message:

Ncat: Failed SSL connection from x.x.x.x: error:1408F10b:SSL routines:SSl3_GET_RECORD:wrong version number

Linux ncat version is at 7.60 and 5.59BETA1 on Windows. Are these incompatible or is my syntax incorrect?

  • 4
    The binary on windows uses a OpenSSL 1.0.0 from 2011. It is probably some incompatible cipher or protocol version - like the old ncat offering SSLv3 which is usually no longer supported by newer version. A packet capture (with tcpdump or wireshark, upload to cloudshark.org) might help to get details about the problem. – Steffen Ullrich Sep 7 '18 at 16:41
  • You are correct, it was just an incompatible version of OpenSSL. Thank you! – 3x14 Sep 15 '18 at 21:04
  • @3x14 how did you resolve this issue? – 3therk1ll Aug 14 at 21:41
-1

Make sure that the Windows Firewall is allowing this connection.

  • A firewall would cause "wrong version number"? It seems to me if you get that error, then the connection was made. – schroeder Sep 14 '18 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.