I run Ubuntu 18.04 and use a VPN service. If I use OpenVPN to manage the connection and connect to a given server, then I can browse the internet as if I'm from that location, except for Netflix, which displays the "we've detected a proxy" message.

However, if I use the VPN service's own connection manager and connect to the same server, Netflix doesn't detect I'm using a proxy.

How can Netflix detect this in one case, but not the other?

2 Answers 2


Assuming that you really end up with the same VPN endpoint the most likely explanation is that you local OpenVPN setup is not strict enough and that you are either using a DNS server without VPN (i.e. some local DNS server in your network) and/or that IPv6 is not covered by your setup and thus bypasses the VPN too. Both are typical configuration problems.

Both of these problems are already discussed on this site, see for example Open VPN has DNS leak and My ISP provides IPv6 natively but my VPN does not support IPv6. You can also check your setup with sites like ipleak.net.


While Steffen may very well be correct, I have a different theory based on my own experiences with Netflix.

I have a VPS through Vultr in which I run both SSH and VPN traffic too. Netflix blocks this IP as a suspected proxy. However, if I bounce my connection through this VPS to my home desktop using a combo of SSH Dynamic port forwarding and TINC Netflix works just fine.

This leads me to believe that Netflix has a blacklist of many popular VPS services, and blocks them all as "Proxies" regardless of if they are or not.

I have no proof one way or another, but occam's razor suggests that while it could be something complex like Steffen suggests ... its most likely just a blacklist.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .