1

I am trying to perform a client side attack with Metasploit on a 32 bit Windows 7 Professional N (SP1) victim. I have Windows Defender and Firewall disabled and Java Control Panel Security set at Medium on the victim.

On the attacker machine, I am utilizing the exploit/multi/browser/java_signed_applet module with the windows/meterpreter/reverse_tcp payload. I have SRVHOST and LHOST set to the IP of the attacker machine.

I left everything else as default. I get the security warning on the victim machine but once I accept the risk and click Run nothing happens, metasploit just hangs at Sending SiteLoader.jar. Waiting for user to click...

Any pointers is appreciated on how I could troubleshoot this further, thanks.

3
  • Does anyone know where SiteLoader.jar normally gets loaded to on the victim machine? I'll try searching the web for that answer.
    – Nemesis
    Commented Dec 18, 2018 at 22:15
  • Tried disabling all security settings on internet explorer (version 8.0.7601.17514) as well. So far I've only found a whitepaper from SANs stating that most payloads are in the AppData folder, but scouring that folder shows nothing. Im completely stuck...
    – Nemesis
    Commented Dec 18, 2018 at 22:34
  • No issues getting a reverse shell on my machine using ncat... yep, pretty much stuck.
    – Nemesis
    Commented Dec 18, 2018 at 22:36

1 Answer 1

0

I'm not sure if this sounds dumb but have you tried clicking/running anything on the victim at the point where you are stuck?

If you have and nothing happens then this may be a bug in metasploit, you might wanna search around about it or report it to communication channels provided for bug reporting.

1
  • 1
    I get the security warning as I would expect on the client machine but when I click that I'll accept the risk and then run it, nothing happens. This is for the OSCP certification so I may end up calling their customer support. They may have a firewall filtering traffic on that subnet.
    – Nemesis
    Commented Dec 19, 2018 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .