1

Getting this error for openssl smime verify

140392937076368:error:21075075:PKCS7 routines:PKCS7_verify:certificate verify error:pk7_smime.c:342:Verify error:certificate is not yet valid

After changing date to - faketime -f "2017-01-01 01:00:00" bash -l

Validity is -

    Validity
        Not Before: Apr  4 09:26:00 2016 GMT
        Not After : Apr  4 09:26:00 2026 GMT

Why error says certificate is not yet valid ?

  • 1
    Which cert are you looking at? Your title says 'rootca' implying a root cert, but a SMIME (or PKCS7/CMS) message is normally signed by a lower-level cert, not a root, and there are often additional intermediate aka chain cert(s). Check all of them. – dave_thompson_085 Dec 21 '18 at 8:27
  • @dave_thompson_085 , I don't have access to the intermediate or pvt rootca ..I am checking only openssl smime verify which uses only the signed file and rootca crt , is it possible to check the validity with just signed file and rootca crt ? – Amruth A Dec 21 '18 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.