Some websites can redirect you, but they're not using http 301 or 302. After that the url will be changed and you can't go back to the previous page using your web browser's back button. For example, ign.com redirects me depending on my ip, the page automatically refreshes and its url becomes www.ign.(country name). In firefox's network console I never see http 302. It just changes to the new url and sets a cookie marking where I'm from. It's not exactly 'refresh' either because disabling auto refresh in about:config has no effect on this.

So what kind of web technology is this and how can I disable this behavior? It's quite annoying.

  • 1
    @forest: One might return a near IP address using DNS but one cannot change the domain in the URL using DNS. Jan 6, 2019 at 7:54
  • 1
    I get a 307 redirect from ign.com to www.ign.com and a 302 redirect from www.ign.com to www.ign.{country}. I have no idea what you see. But redirects might also be done using Javascript. Anyway - I don't think that this is an information security problem at all. Jan 6, 2019 at 7:56
  • @SteffenUllrich You're right, I looked at inspect element again and got a 302.
    – forest
    Jan 6, 2019 at 7:56
  • OP, perhaps you have not set "Persist logs" in the Network Monitor? If it is not enabled, then the first redirect may result in the logs being cleared. But anyway, I don't see how this is related to security.
    – forest
    Jan 6, 2019 at 7:57
  • @forest you are right, after toggling "persist logs" on I see the redirect responses. If I click on a link from search results then these sites can redirect me to anywhere they want, and I can't prevent this by any means, thus I thought this could be a security concern. Jan 7, 2019 at 11:44

1 Answer 1


They are using HTTP 301 (Moved Permanently) and HTTP 302 (Found) like anyone else. HTTP 301 can be cached by the browser, which is likely why you aren't seeing it in the network tab of devtools. When I type in the url bar http://ign.com it redirects me with HTTP 301 to http://www.ign.com/. Then it redirects me with HTTP 302 to http://[country subdomain].ign.com/. Finally it redirects me to HTTPS with HTTP 301 to https://[country subdomain].ign.com/ with HTTP status code 200.

To prevent the unnecessary redirects, you can install a proxy and strip out the redirects.

Not the answer you're looking for? Browse other questions tagged .