2

I can not get gpg to prompt me for my passphrase when I want to decrypt a file. I tried including:

default-cache-ttl 0
max-cache-ttl 0

(also flipped the bit to 1)

within ~/.gnupg/gpg-agent.conf and then running either: gpgconf --reload gpg-agent or echo RELOADAGENT | gpg-connect-agent or killing the daemon but none of that works.

I wonder if GPG Keychain is doing something wonky under the hood? (Note I am on macOS High Sierra 10.13.6)

gpg (GnuPG/MacGPG2) 2.2.10
libgcrypt 1.8.3

GPG Keychain Version 1.4.6 (1514)

My gpg.conf

# Avoid information leaked
no-emit-version
no-comments
export-options export-minimal

# Displays the long format of the ID of the keys and their fingerprints
keyid-format 0xlong
with-fingerprint

# Displays the validity of the keys
list-options show-uid-validity
verify-options show-uid-validity

# Limits the algorithms used
personal-cipher-preferences AES256
personal-digest-preferences SHA512
default-preference-list SHA512 SHA384 SHA256 RIPEMD160 AES256 TWOFISH BLOWFISH ZLIB BZIP2 ZIP Uncompressed

cipher-algo AES256
digest-algo SHA512
cert-digest-algo SHA512
compress-algo ZLIB

disable-cipher-algo 3DES
weak-digest SHA1

s2k-cipher-algo AES256
s2k-digest-algo SHA512
s2k-mode 3
s2k-count 65011712

My gpg-agent.conf

# Disable agent cache   
default-cache-ttl 0
max-cache-ttl 0
2

Solved the issue. TL:DR GPG Suite was saving the password in macOS Keychain (not GPG Keychain)

More information here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.