1

I have read many threads on StackExchange and some other blogs but none helped me. The issue is with aircrack-ng on Kali Linux. It gives me error No such BSSID available when I run aireply-ng. I think it is because of not having mon0 when I run airmon-ng.

root@kali:~# uname -a
Linux kali 4.19.0-kali1-amd64 #1 SMP Debian 4.19.13-1kali1 (2019-01-03) x86_64 GNU/Linux

I have updated the driver of usb wifi adaptor; RTL8812AU and it is the output of iwconfig.

root@kali:~# iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  Mode:Monitor  Frequency:2.422 GHz  Tx-Power=18 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

I think it needs to show the name of the adapter in the monitor mode, something like mon0 or wlanmon0 but it shows only 3 or some other numbers.

root@kali:~# airmon-ng start wlan0

PHY Interface   Driver      Chipset

phy0    wlan0       88XXau      Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter

        (mac80211 monitor mode already enabled for [phy0]wlan0 on [phy0]3)

I have read on some blogs that it does not really matter if there is no mon0; but it doesn't work at all and just give me the following error, No such BSSID available.

root@kali:~# aireplay-ng --deauth 100 -a MAC_OF_AP -c MAC_OF_TARGET wlan0
16:56:02  Waiting for beacon frame (BSSID: MAC_OF_AP) on channel 3
16:56:12  No such BSSID available.

P.S. - I have tested it on Windows 10 and Ubuntu 18.10 hosts as well as Kali 2019 and ParrotSec. Both have the same issue.

3
  • 1
    Are you actually setting MAC_OF_AP and MAC_OF_TARGET to the correct values in your aireplay-ng command?
    – Polynomial
    Mar 13 '19 at 0:28
  • Did you run airmon-ng check kill before airmon-ng start wlan0?
    – they
    Mar 13 '19 at 3:07
  • Are you on the right channel? I see that the AP is on channel 3, and when you started airmon you selected no channel, try airmon-ng start wlan0 3 Also before that do the check kill command as @they suggested.
    – Azteca
    Mar 13 '19 at 5:19
0

In your output for airmon-ng, it says that monitor mode has been enabled for [phy0]3. This means that a new interface named 3 has been created which is using monitor mode.Therefore, 3 is the interface you should use along with aireplay or any other tools of the aircrack-ng suite. Try:

aireplay-ng --deauth 100 -a MAC_OF_AP -c MAC_OF_TARGET 3
0

There are a few adjustments that you can make to the airmon-ng configuration. I recommend that you run through this process to ensure you can pick up your monitor interface.

  • Start with viewing your interfaces with a quick iwconfig

    root@kali:~# iwconfig

  • Once you view the interface you want, ensure in the interface details that the mode is set to monitor or managed "Mode:Monitor".

I noticed that your interface "wlan0" was already set to monitor, which is why you got the message "(mac80211 monitor mode already enabled for [phy0]wlan0 on [phy0]3)"

If it is set to managed, bring it up with airmon-ng, although remember best to set the channel else you'll just get something random.

  • Set the Monitor mode with

    root@kali:~# airmon-ng start wlan0 1

  • Then try an airodump to confirm you can sniff packets with

    root@kali:~# airodump-ng -c 1 wlan0mon (check iwconfig since wlan0 may either be in monitor mode already, or will switch when you perform a airmon-ng start command).

There doesn't seem to be a configuration issues with your aircrack-ng suite. Please try the above and advise if you're still having issues.

Best of luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.