1

I have tried to import a public key of someone into enigmail. The import failed silently (nothing absolutely happened, not even an error). I tried key from file and from clipboard.

Then I used gpg --import on the file and the key appeared in gpg --list-keys but untrusted. So I used gpg to trust the key completely ("uneing." in German).

Enigmail now shows the key but with a Red box. I can not select the key and use it to encrypt messages.

gpg --list-keys output

pub      0E/xxxxxx 2018-03-07
uid       [ uneing.] xxxx <xxxx@xxxx.xxx>

When I use key-management in Enigmail to validate the key via right-click "Key properties" and Certify button, I select "I have checked very carefully" and an own key for signing. After clicking Ok again nothing happens, key is still "invalid" and no error appears.

Enigmail-Verison: 2.0.10 (20190324-1211)

  • Is the key expired? – David Apr 8 at 22:05
  • I think not. It says :public key packet: version 4, algo 19, created 1520407117, expires 0 unknown algorithm 19 – user6329530 Apr 9 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.