0

I found that in the past, the WordPress version 2.0.6 and earlier was vulnerable. The remote host fails to properly sanitize input to the tb_id parameter of the wp-trackback.php script before using it in database queries.

I didn't found any countermeasure for this somewhere or if the vulnerability is eliminated to version newer than 2.0.6.

I also found that PHP's register_globals setting must be enabled and that the remote version of PHP needs to be older than 4.4.3 or 5.1.4 for this to be vulnerable.

  • There must be a way for you to figure out if an open source project is still vulnerable by this very specific vulnerability. – Birb Apr 24 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.