0

First some context. I am Working for a company learning about Security Web Services. They have a main application and a blog. I've been looking vuln. in the main webapp for a while, but then I start looking in the blog that it was made with Wordpress Having the version 5.1.1 getting the info with wpscan command.

Wpscan command also says that the blog has:

  • Multiple Vulnerabilities (Including SQLI) because of WPLM <=3.1.7.2
  • Cross-Site Scripting (XSS) in Accept-Language Header because of WPLM 2.9.3-3.2.6

All because of the plugin "sitepress-multilingual-cms" That has the version 2.0.4.1

I am trying to exploit a reflected XSS vulnerability mentioned in WPML Multiple Vul. , number 3, says that in the main link of the blog triggering the link "https://your.wordpress.blog/?icl_action=reminder_popup&target=javascript%3Aalert%28%2Fhello+world%2f%29%3b%2f%2f" must trigger the alert popup confirming the vulnerability.

Ther problem here is that when i try to trigger the link nothing appears, and stand in a normal way in the main page. I am doing something wrong? Is it possible that new versions of Wordpress could fix this issue? Or new versions of the browser?

Now what I am trying to explain is that the vulnerability exist and it still dangerous even if I am not able to exploit it. I am right?

If it is exploitable I'd like to learn how to.

Could be just the syntax is not comtible with my browser.

  • Info About First Vulnerabiltiy

-Reference: https://wpvulndb.com/vulnerabilities/7843

-Reference: http://seclists.org/bugtraq/2015/Mar/60

-Reference: http://packetstormsecurity.com/files/130810/

-Reference: https://www.exploit-db.com/exploits/36414/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.