i ran aireplay-ng -9 wlan0 and it seems that my intel PRO/Wireless 5100 AGN adapter does not support injection. i use Ubuntu 10.10 64bit (2.6.35-25-generic kernel). is it possible to make the adapter have injection capability? if yes, how?

  • Is this a security question? I don't see the connection...
    – AviD
    Commented Feb 10, 2011 at 23:30
  • 1
    It should be moved to Server Fault.
    – Steve
    Commented Feb 10, 2011 at 23:41
  • 1
    @SteveSyfuhs @AviD This question has to do with Wireless Penetration testing which is 100% Security. This 'can' probably be put on SF but someone over there is going to say it has to go here.
    – WalterJ89
    Commented Feb 11, 2011 at 0:37
  • 1
    @WalterJ89 - I agree that Wireless Penetration Testing is in general an IT Security topic. However, this appears to be more of an application/OS/hardware troubleshooting question, which is probably more appropriate for SuperUser or ServerFault.
    – Iszi
    Commented Feb 11, 2011 at 15:51
  • 1
    @Iszi While I agree that this quest could get away on SuperUser or SF you have to realize that all of these sites do overlap somewhere. This question while based on getting a piece of hardware working, is more about getting that hardware working in such a way that you can use it for security. This is more of a discussion for the meta site.
    – WalterJ89
    Commented Feb 12, 2011 at 4:33

3 Answers 3


Try using Backtrack or Blackbuntu. Those two distribution have better driver support for packet injection. Some wireless cards need specially modified drivers. Once you figure out which one you need you can install it in Ubuntu. Backtrack and Blackbuntu are worth using for that purpose though.

Also it is worth noting that you MAY have better luck using a 32-bit OS, Backtrack for one is only 32-bit because most drivers and tools work better. I can't vouch for there being any issues with using a 64-bit OS though.

Good luck in your Penetration Testing. (I hope that's what your purpose is)

  • i tried backtrack 4 final release...did not help. i have read some workarounds including kernel patching but i probably will be better off buying a dongle that supports injection.
    – sterz
    Commented Feb 13, 2011 at 19:00
  • check my edit plz Commented Feb 13, 2011 at 20:58

On a brand new install I did this:

first switch to root:
nano /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

make it look like this:
#options iwlagn 11n_disable=1
options iwlagn 11n_disable=1 swcrypto=1

Reboot and or in a terminal do something like the following

root@main:/home/bildr# modprobe -r iwlagn    
root@main:/home/bildr# modprobe iwlagn
root@main:/home/bildr# killall nm-applet    
root@main:/home/bildr# airmon-ng start wlan0    

Found 4 processes that could cause trouble.    
If airodump-ng, aireplay-ng or airtun-ng stops working after    
a short period of time, you may want to kill (some of) them!    

PID Name    
1028    NetworkManager    
1030    avahi-daemon    
1031    avahi-daemon    
1176    wpa_supplicant    

Interface   Chipset     Driver    

wlan0       Intel 4965/5xxx iwlagn - [phy0]    
                (monitor mode enabled on mon0)    

root@main:/home/bildr# aireplay-ng --test mon0    
15:25:36  Trying broadcast probe requests...    
15:25:36  Injection is working!    
15:25:38  Found 4 APs    

15:25:44  00:21:29:DB:C4:B4 - channel: 11 - 'Turbeville'    
15:25:45  Ping (min/avg/max): 1.418ms/31.889ms/47.236ms Power: -54.60    
15:25:45  30/30: 100%    

root@main:/home/bildr# airmon-ng stop wlan0    

Interface   Chipset     Driver    

wlan0       Intel 4965/5xxx iwlagn - [phy0]    
                (monitor mode disabled)    
mon0        Intel 4965/5xxx iwlagn - [phy0]    

root@main:/home/bildr# airmon-ng stop mon0    

Interface   Chipset     Driver    

wlan0       Intel 4965/5xxx iwlagn - [phy0]    
mon0        Intel 4965/5xxx iwlagn - [phy0] (removed)    

root@main:/home/bildr# modprobe -r iwlagn    
root@main:/home/bildr# modprobe iwlagn
root@main:/home/bildr# killall nm-applet    
bildr@main:/home/bildr# nm-applet &
  • which distro is this?
    – sterz
    Commented Feb 14, 2011 at 12:26
  • ubuntu 10.10 and 11.x both work fine. bt4 is ubuntu based so it should work there too. if you go to the trouble of installing the drivers, it should work on anything debian derived. (may work on fedora family too, but I stay away from rmp based distros) Commented Feb 14, 2011 at 13:37
  • @sterz is there another distro you are worried about? if not plz accept. if yes plz tell me so I can make sure it works there Commented Feb 18, 2011 at 7:06
  • (sorry for the late reply) that doesnt work on ubuntu. at first, the test tells me that i can inject but when i run it parallel to airmon-ng it fails.
    – sterz
    Commented Apr 14, 2011 at 19:23
  • I verified injecting fine on my end with airmon-ng. Are you sure hwcrypto is disabled? That will pooch it EVERY time(well if you're injecting into wpa/wep). To verify...try injecting into open and see if it works. I am absolutely sure it works on my card. May be some weirdness with a particular chipset(I ran a driftnet and replace demo off this laptop with some...less than stellar images). Commented Apr 16, 2011 at 16:58

I really can't remember if I ever got it to work on my ASUS X5AVN with Intel 5100 wireless network card. But I remember that I succesfully cracked a couple of test networks, but I used a USB dongle which supported Injection and Monitoring mode. I didnt do it the sufficient way, I used two laptops, my main laptop with the 5100 wireless and another laptop with backtrack and the USB dongle. My brother has my dongle at the moment, so I can not recall what name it is, but it supports bigger antennas.

I can recommend this site to find compatible cards for injection and monitoring mode.

Aircrack compatible cards

I have a little "bonus" info for you if you get it up and running, a person called G0tm1lk created a nice script for automatisation. I recommend you learn aircrack-ng before you use this script.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .