-1

I just installed mitmproxy tool. I want to run it. Once I type: sudo mitmproxy I get this error:

Error starting proxy server: OSError(98, 'Address already in use')

I searched and found some suggestion for changing the port by typing: sudo mitmproxy -p 99999 However, I think this may cause me problems as I wan to do HTTPS traffic manipulation.

Can you please help me solve the error?

1
  • 5
    Since TCP ports go up to 65535, that's not a very useful suggestion. – Teun Vink Jul 22 '19 at 14:11
0

So i had time to look into this.Here is how you do it.

In Firefox:-

  1. GO to options
  2. Then preferences
  3. In the search type network.
  4. click on settings in network proxy
  5. select manual proxy configuration
  6. Http proxy 127.0.0.1 port 8080
  7. select use this proxy for all protocols and then click ok
  8. Now listen on port 8080 using mitm proxy and you will intercept all traffic on loopback.

Obviously install root CA if you want to listen for HTTPS traffic.

This is for listening on loopback like you mention.Use arp poisoning or similar for other devices on the network

4
  • Thanks. But Use manual http proxy in firefox/chrome and give another port. First, I need to use the internet while using mitmproxy. So I do not think I can kill the applications listening in this port. Second, where can I get the manual proxy to configure my Chrome/Firefox with? I do not have any. – randomname Jul 22 '19 at 17:18
  • in firefox go to preferences and then search network then check "use manual proxy option" specify 127.0.0.1 and whatever port you want.Then listen on the that port – yeah_well Jul 22 '19 at 17:39
  • If I set a proxy 127.0.0.1 port 999 in my browser I can not browse the Internet (from the browser). All pages can not open. How to use mitmproxy and be able to use the Internet as normal? – randomname Jul 22 '19 at 18:04
  • Lemme look into it and i will answer you tmrw – yeah_well Jul 22 '19 at 18:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.