3

I'm using BurpSuite to intercept the HTTP/HTTPS requests sent when logging in on https://www.nike.com/. I'm trying to achieve this with the following step:

  1. Opening BurpSuite and Firefox

  2. Turning on the proxy intercept

  3. Turning on FoxyProxy on Firefox

  4. Opening the website and trying to logging

These steps usually work for me, but in this case, I'm getting a "we are unable to connect to our servers" error without anything appearing on the intercept tab when trying to logging (I have tried turning off the intercept feature but it still yields the same issue, so I think it might be a proxy and certificate problem).

To clear things up:

  • I'm running the latest versions of BurpSuite and FireFox.

  • I have installed and reinstalled the BurpSuite certificate using this guide.

  • I've tried all of this on my iMac, MacBook and iPhone all of these devices yield the same issue

Here bellow is the error message I'm getting: error message on the website

Here are my BurpSuite Proxy setting: proxy settings

(in the Certificate tab I just have Generate CA-signed per-host certificates selected)

I have been using BurpSuite for over 2 years now and it's the first time I'm facing such an issue, any help is appreciated


I have shared my question with the Portswigger support (the team behind BurpSuite) and got the following response:

Hi

Thanks for your message.

We have reproduced the issue in our testing environment.

It looks like Nike.com are performing a fairly sophisticated check to stop automated tool from accessing parts of their site. Please let us know if you need any further assistance.

Cheers

Liam Tai-Hogan

PortSwigger Web Security

  • 1
    Just tested, on a normal environment everything should work. Maybe the the websites servers were down? – Raimonds Liepiņš Jul 29 '19 at 8:57
  • @RaimondsLiepiņš Thank you very much for your reply! Have you tried logging by clicking "NikePlus Join / Log In To Nike⁠Plus Account" in the top right corner (Feel free to enter a random email and random password). If you already have tried this out may I ask you what browser you are using, I have tried using FireFox and Safari (on iOS) and it yields the same problem. – Fozoro Jul 29 '19 at 9:07
  • As an aside, is there any kind of opsec consideration that you should be applying to this question? – Ian Jul 29 '19 at 9:58
  • @Fozoro I tried it on Mozilla Firefox – Raimonds Liepiņš Jul 29 '19 at 14:20
  • @RaimondsLiepiņš I have been on this problem for over 7 hours still haven't found a solution do you have any idea on what I could possibly to? here are some additional pictures of my configuration (imgur.com/a/tNjv25e) – Fozoro Jul 29 '19 at 14:21
2

This problem comes from the configuration of unite.nike.com, which is the domain used to login users. The server replies with a 403 Forbidden response, so the AJAX request fails, and the site displays the "An error occurred" message.

This domain is protected by Akamai, and it seems to have a very strict security configuration to detect MitM / bots: I can't manage to perform a cURL request against it, so this is not a traffic interception issue.

My guess is that the server is detecting a browser-specific fingerprint, though I haven't figured out which one exactly yet.


The Burp Suite team needs to fix their proxy, since it should be as transparent as possible for a remote server.

Since the Postman extension doesn't have any trouble to fetch the page, any browser extension capable of traffic interception should work, since all its requests will be done in a browser environment, likely to preserve the fingerprints which are detected by the server.

| improve this answer | |
  • Thank you very much for your answer I have noticed that this problem might be solved by using invisible proxying (I just have a but of trouble implementing it properly as I can’t listen to the port 443 through burpsuite). If you are familiar with invisible proxying this might be the solution. Thanks for your help in advance – Fozoro Aug 10 '19 at 5:49
  • @Fozoro: Unfortunately I'm not sure how invisible proxying would help here, since it would still remove the browser-specific fingerprints. – Benoit Esnard Aug 12 '19 at 9:19
  • That's a fair point. Do you have an idea on how I can not remove the fingerprint? – Fozoro Aug 12 '19 at 9:30
  • @Fozoro: I would just wait for Burp Proxy authors to fix their proxy. As you can see in that research, there are a lot of technical details which can be detected. You can also try other proxies to find which ones aren't detected. – Benoit Esnard Aug 12 '19 at 9:37
  • Thank you very much for your quick reply based on Burpsuite reply (that I included in my question) they told me that it’s more of an issue with nike than with burpsuite (so I’ Not sure if they are planning to fix it any time soon). I would also like to add that I was able to intercept using postman (but I really don’t like the program). What so you mean using “other proxies”. – Fozoro Aug 12 '19 at 9:44
0

"Error network is unreachable (connect failed)", This is an error generated when i dropped the feeding internet-connection of burp was listening on port 8080 and correctly configured in the browser.

Error provided: "An error occured we are unable to connect our servers right now. Please try again later.", it seems that this may be an error that was generated by nike itself, because if it was burp, it would like like above, i think that it has nothing to do with burp nor firefox, also there is some information missing here to reproduce it (that would make this question unclear).

Anyway both errors do have a similar status, above the fact that i don't know the errno of the error you gave, irrespectively how both error's were triggered, but as said i think burp has nothing to do with this problem.

| improve this answer | |
  • Thank you very much for your answer, I’ll try using a different computer today is there any additional information I can provide? The funny thing is that when I stop using the burpsuite proxy the login works perfectly. It stops working when I use the burpsuite proxy. Do you have a clue on how 8 can solve this? – Fozoro Jul 29 '19 at 12:17
  • Can you add technical details like current config in burp etc? – user211258 Jul 29 '19 at 12:21
  • Thank you for the quick reply, here are a couple of photos (imgur.com/a/tNjv25e) of the configurations I'm using (do tell me If there are other configurations you want to see). Thanks for your help in advance – Fozoro Jul 29 '19 at 12:37
  • I just tested this out on another computer and I face the same error as before – Fozoro Jul 29 '19 at 13:20
  • I never faced this before, but it can help to reset "Intercept Client Requests" in the Proxy tab then "Options", if it works note that in the question. – user211258 Jul 29 '19 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.