-1

Earlier today, I wanted to access the admin web server of my router. But for some reason, I was not able to access it, the web browser telling me there was no server on that address.

I had internet connection, so I was a bit surprised. I first pinged my router, which worked fine. Then, after checking my route, which seemed correct, I decided to make a traceroute. And I got that :

$ traceroute to 198.168.8.1 (198.168.8.1), 30 hops max, 60 byte packets
 1  192.168.8.1  1.184 ms  2.162 ms  2.660 ms
 2  * * *
 3  10.4.2.17  44.729 ms 10.4.0.17  64.094 ms 10.4.1.17  64.258 ms
 4  10.187.154.251  64.533 ms  64.487 ms  64.441 ms
 5  77.136.134.1  64.304 ms  64.250 ms  64.198 ms
 6  77.136.10.34  64.043 ms  63.869 ms  62.807 ms
 7  77.136.10.245  68.157 ms  41.670 ms  41.429 ms
 8  77.136.10.245  40.912 ms  45.589 ms  48.417 ms
 9  198.32.118.240  168.585 ms  168.633 ms  169.538 ms
10  68.67.63.81  175.225 ms  169.396 ms 192.252.143.186  169.601 ms
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * 198.168.8.1  152.839 ms *

This seems weird to me and extremely suspicious.

So I tried on another computer and the traceroute seems normal, one hop and that's it, but the web server was not accessible either. That same computer restarted on Windows and tried to access the router's web server, and at that point it worked. It also worked again on my first computer, and the traceroute was once again normal (one hop).

After some time, it is now again showing me a traceroute going out of my home LAN before going back. But now, the router's web server works.

So now, I'm lost...

Is there any legit possible explanation why it is going outside my LAN when I do a traceroute ?

I don't have any VPN on at the moment and here are my routes :

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.8.1     0.0.0.0         UG    600    0        0 wlp3s0
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
172.22.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker_gwbridge
192.168.8.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp3s0

I'm on Linux, and my router is a 4G router Huawei B525s-23a

  • 5
    The real IP address of the admin interface of your router is 192.168.8.1 not 198.168.8.1, i.e. you have a typo. The first IP address is a non-routeable local IP address which is used for internal networks, the second IP address is an external one which belongs to a netblock of softimage. – Steffen Ullrich Sep 10 at 18:34
  • 1
    ahah, yes indeed. Ah, the little things... Thanks. – ogr Sep 10 at 18:39
0

As Steffen Ullrich mentions in his comment, the problem was a simple typo in your traceroute script.

You wrote

traceroute 198.168.8.1

but it should be

traceroute 192.168.8.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.