3

Currently I am trying to fuzz the request I sent to Repeater. However if I put a new line (using Enter key) inside repeater's text window, burp on background really creates a crlf.

My goal:

Send a request, which contains only a newline without carriage return.

What I tried

I tried to use \n (as it is common in a lot of programming languages). However burp's Repeater treats \n as set of two characters - \ and n.

burp repeater

Question

Is there any way how to pass standalone newline character without carriage return inside Request stored in Repeater?

So far I tested this using my workaround in bash console, which is not-elegant at all:

curl https://mykey.example.com --header "Content-Length: 1" --header $'\nTransfer-Encoding: chunked'

Any insights appreciated.

4
  • 1
    Are you able to remove the carriage returns in the hex tab?
    – user
    Commented Oct 10, 2019 at 18:18
  • Yes sure, but in hex tab you can only replace carriage return, you cannot simply delete it.
    – Fusion
    Commented Oct 10, 2019 at 18:21
  • I mean, you could technically just delete a single character before the new line in the raw tab, then replace the hex data with the character you deleted...
    – user
    Commented Oct 10, 2019 at 18:22
  • maybe you could use multi-byte for example UTF-8 encoding of the newline character
    – LLub
    Commented Oct 10, 2019 at 18:26

1 Answer 1

4

Thanks to @user, who led me to the correct answer - You must simply use hex tab, and then find carriage return character you want to delete. Afterwards just click the Right button and press Delete Byte option.

1
  • 1
    Once you have a line set up correctly, try copy-pasting it in the raw textbox. It might save the fact that you don't have a carriage return in the copied data, which would probably speed up the process of making new requests.
    – user
    Commented Oct 10, 2019 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .