0

I absolutely cannot get traffic to go through Ettercap. I feel like I've done everything correct, but it always just ends up with my targeted machines getting Timeout error when trying to load.

I allowed the connection functions using iptables in the config (for ipv6 as well), I also allowed ip forwarding. I've changed the iptables command based on various lookups on the internet when investigating this problem.

I've tried combinations of the gateway being target 1 and target 2 as well. I'm allowing ARP Poisoning. I've tried this with dns_spoofing, I've tried this with sslstrip. Neither will work. And then I've simply tried it with just ARP Poisoning and it won't work. I'm having trouble find the same problem online as well. What could be wrong?

The Conf File
In the conf I have changed ec_uid and ec_gid to 0 (but I have tried it with the original as well).

My redir_commands are currently:

iptables -t nat -A PREROUTING -i %iface tcp --dport %port -j REDIRECT --to-port %rport
iptables -t nat -D PREROUTING -i %iface -p tcp --dport %port -j REDIRECT --to-port %rport

(I've used the original iptable redir-commands in various config combinations as well)

When Running:

before running I enter: sysctl -w net.ipv4.ip_forward=1

and then run the GUI with ettercap -G

  • 1
    Have you run a packet capture to see what's going on? – schroeder Feb 25 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.