0

I have a personal service which is deployed on one VPS. The service works based on http requests, and it is due specific goal and handling three types of requests. The order matters in the requests. Client send requests, it usually takes something between 30s to 6min to get a response (and it's OK). When I set it to perform short task (30-60 seconds) everything is OK. But when I have longer request (3-4 minutes), it seems someone with another IP replicate the requests I sent after 2(almost) minutes.

times are in seconds

  1. at time 0 I send a request to startup the system from IP1 (my IP)
  2. at time 15 I send a request to run the system from IP1 (my IP)
  3. at time 18 I send a request and ask for the result which should take about 500 seconds from IP1 4. at time 130 the system gets a request from another IP (IP2) to startup the system
  4. at time 154 the system get a request to run the system from IP2

I checked IP2, its not on any sort of black list, it seemed it's from amazon aws. My mistake was that I have left the port open and made it possible, I closed it and now I'm using ssh port forwarding. It works fine now. What I don't understand is: "is this something normal? is this some sort of attack? Am I paranoid?"

0

Your scenario is not described completely and is difficult to understand what is the issue, however you can do the next checks:

  • Your application should use TLS, so all your requests will be encrypted over the internet, is your application using HTTP?
  • You should review your application, according your explanation this could be a bug in your application. You should provide more information about it.
  • On the destination host, you could pcap file the requests and later try to discover what is the issue and where the other IP came from.

Hope it helps

| improve this answer | |
  • Your right, its http, it should be over tls. I tried to look for a bug, but after closing the port, the problem is solved. Maybe because it's not tls someone managed to replicate the requests. – Vahid Mar 29 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.