0

My first time doing MITM attack on my own network. I've used arpspoof to redirect the victim's (my another pc) traffic to my machine and I've enabled packet forwarding. To view the traffic I ran dsiff. However this doesn't show any traffic even though I'm visiting Youtube... I launched wireshark and I got so many packets. Mostly of the victim's. I'm not running promiscuous mode so I guess it's a success. urlsnarf has the same problem as dsniff and also mitmproxy. All these tools don't show anything. So what's going on? How can I run dsniff?

In wirehark, however, I can't find any packets from my victim's machine using tcp or http: I make GET requests to google.com and I can't get any. I've used the ip.src=xxxx filter but most of the packets use SSDP,IGMPv2, NBNS... Not a sign of TCP or UDP. When I remove the filter I receive lots of UDP pacekts. I'm running youtube. And the ip source address is indeed one of Google

I don't know what to include as info. Im running Kali Linux i686, 5.4.0-kali2-686-pae

dsniff
Listening on wlan0

``wlan0`is the right network interface

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.