1

When I look up a site on wayback machine, I click through a couple of links on the site, and then instead of loading the page, it downloads a file called "default.exe".

Since I was expecting a page to load, not an .exe to download, it roused suspicions.

Is this a common thing, and is there any way to figure out what's going on?

I'm 99% sure the site that wayback machine indexed wouldn't have tried to download an exe, although I could be wrong. The archived site is ~20 years old and was running on free hosting at the time (perhaps serving exe's was common back then)

enter image description here

1
  • 1
    Try submitting the file to a service like VirusTotal. Feb 1 '21 at 14:32
1

That might also be a snapshot of a misconfigured web server -- back then it was normal to generate web pages from CGI programs, which would be addressed as if they were regular files, and only their location or an "executable" bit set on the binary would indicate to the web server that the file should be executed and its output sent instead of the file itself.

It could also be a twenty years old virus.

1
  • Very interesting, definitely hadn't come across those before. Regarding "It could also be a twenty years old virus." ... the same thought had crossed my mind. I wonder if wayback machine would do any sort of filtering, or if sites are preserved just as they were (viruses and all)
    – stevec
    Feb 1 '21 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.