We have a web application on https port with server certificate valid from 01/01/2021 and valid to 31/12/2021. Due to some constraints the clients which are going to use web application are behind current date, while the server is on current date time. There is no issue in production as server and client both are on the current date time. When i try to connect to web application from client (whose date is of July 2019), i get SSL error in chrome.

Your clock is ahead. A private connection to "ServerName" can't be established because your computer's date and time (Wednesday, July 31, 2019 at 11:00:13 PM) are incorrect. NET::ERR_CERT_DATE_INVALID Update date and time. To establish a secure connection, your clock needs to be set correctly. This is because the certificates that websites use to identify themselves are only valid for specific periods of time. Since your device's clock is incorrect, Google Chrome cannot verify these certificates.

Also in the URL following error is there

This certificate has expired or is not yet valid.

I know i can change the client date to current date time and its working. But since there are some constraints i cant do that. I googled and not found any solution, Is there any option to disable the validity check or any other option to proceed with.

Thanks in advance.

1 Answer 1


There is no way to disable the expiration check of a certificate. If there is a way to accept the certificate anyway depends on the use of explicit HSTS (via Strict-Transport-Security HTTP header) or implicit HSTS (i.e. specific domains like .dev) always require HTTPS. If HSTS is used a certificate which is considered invalid cannot be accepted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .