1

I'm trying to enumerate a Microsoft Access database using sqlmap, in particular I run this command:

sqlmap -r http.txt --risk 2 --dump-all

Anyway it seems is not retrieving a single information. Am I missing some switch? I already tried --dbms="Microsoft Access" and the result was the same. sqlmap output is reported below.

[17:15:37] [INFO] sqlmap will dump entries of all tables from all databases now
[17:15:37] [INFO] fetching tables for database: 'Microsoft_Access_masterdb'
[17:15:37] [WARNING] the SQL query provided does not return any output
[17:15:37] [WARNING] in case of continuous data retrieval problems you are advised to try a switch '--no-cast' 
[17:15:37] [INFO] fetching number of tables for database 'Microsoft_Access_masterdb'
[17:15:37] [WARNING] running in a single-thread mode. Please consider usage of option '--threads' for faster data retrieval
[17:15:37] [INFO] retrieved: 
[17:15:37] [WARNING] unable to retrieve the number of tables for database 'Microsoft_Access_masterdb'
[17:15:37] [WARNING] cannot retrieve table names, back-end DBMS is Microsoft Access
[17:15:37] [WARNING] cannot retrieve column names, back-end DBMS is Microsoft Access
[17:15:37] [INFO] fetching entries for table 'users' in database 'Microsoft_Access_masterdb'
1
  • Sqlmap.org says they offer full support. Check the docs as well as your favorite search engine. Mar 4 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.