0

Guys does anyone know how I can change the port that ettercap runs? I need it to run on port 8080.

When I try to run sudo ettercap -G it presents me with this error:

ERROR : 13, Permission denied
[/build/ettercap-gsX8lN/ettercap-0.8.3.1/src/ec_capture.c:capture_getifs:114]

Can't open raw Bluetooth socket: Permission denied 

Being that I have root, as a solution I thought of changing the default ettercap port, does anyone know how to do this?

0

I am assuming that you are using Kali or another Debian based distro. All of ettercap's config files are found in /etc/ettercap/ by default. However your question does not expand on what would be running on 8080. ettercap is a network layer recon and exploitation tool. It doesn't really run an application on a certain port. If you are trying to redirect traffic to a web service running on port 8080 that would be another issue. If purely launching the graphical interface is giving you the issue above, you need to add sudo to the beginning of your command or give privileges to your current user to run ettercap by using groups and such. Please explain your issue in more depth.

6
  • Like I said ... I used sudo ettercap -G but it didn't solve the problem :( – Maria Eduarda Mar 8 at 22:12
  • It is talking about a bluetooth interface. Are you sure that your chip supports promiscuous mode? Also are other users allowed to capture packets on the system? Part of troubleshooting would be to login as root and check if the application works then. – e-Euler Mar 8 at 22:14
  • I'm logged in as root, I don't even want to use any bluetooth interface, I just want to use ettercap because I want to learn how to do the DNS spoffing attack in practice – Maria Eduarda Mar 8 at 22:31
  • I would make sure everything is updated ``` apt-get update && apt-get upgrade ``` restart the computer and try again if it still doesn't work ``` apt-get purge ettercap ``` and reinstall. pay attention to the options presented to you and think how they will effect each user. Let me know what happens. I have tried to recreate your issue and can not. – e-Euler Mar 8 at 22:45
  • @MariaEduarda maybe try bettercap? – multithr3at3d Mar 9 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.