1

I don't know if this is the right forum for this kind of question.

I was trying to intercept traffic from Twitter for Android app and for that I needed to bypass the SSL pin they implemented. Basically I was following this tutorial and I got it to work.... sort of:

Spawned `com.twitter.android`. Resuming main thread!                    
[Android Emulator 5554::com.twitter.android]->
[.] Cert Pinning Bypass/Re-Pinning
[+] Loading our CA...
[o] Our CA Info: O=mitmproxy, CN=mitmproxy
[+] Creating a KeyStore for our CA...
[+] Creating a TrustManager that trusts the CA in our KeyStore...
[+] Our TrustManager is ready...
[+] Hijacking SSLContext methods now...
[-] Waiting for the app to invoke SSLContext.init()...
[o] App invoked javax.net.ssl.SSLContext.init...
[+] SSLContext initialized with our custom TrustManager!
[o] App invoked javax.net.ssl.SSLContext.init...
[+] SSLContext initialized with our custom TrustManager!

but now whenever I try to login I get a Toast saying You've exceeded the number of attempts. Please try again later. I also get api_error_code=243 in mitmproxy saying that I should try again in an hour. The issue is that I did this yesterday and when I tried today I still get the same error. Does anybody know what might be the issue?

4
  • Looks like your connection to Twitter is being rate limited because you tried connecting to their API too many times. It might just be a temporary IP block in which case, you could just use a VPN until your IP is unblocked. – Marc Woodyard Mar 14 at 10:47
  • Have you tried it again without MITM? There might be a bot detection at Twitter and since the TLS fingerprint of Twitter via MITM looks different from the original fingerprint of the app it might be considered a bot. – Steffen Ullrich Mar 14 at 11:24
  • @SteffenUllrich tried this and it didn't work, the same issue – bvr Mar 14 at 12:30
  • @MarcWoodyard I don't really know how to connect my emulator to a VPN. I read that all I need to do is simply turn on VPN and restart emulator but that did nothing. I managed to create new account while the script was running and I'm logged in and mitmproxy is getting all the traffic so I guess that is a workaround but not a solution. – bvr Mar 14 at 12:31
1

Ok so it turns out everything worked fine I just got IP blocked. Turned on a VPN and there are no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.