I had two copies of a Veracrypt encrypted drive, and from them, I made two additional copies of the drive, which was a few days ago. the two copies had the exact same SHA hashes of the original two copies when they were created, the data should be the same and with no data loss.

Both copies worked and mounted perfectly the day that I made them, but now both of them say that the password is wrong when I try to mount, and when I use the backup header instead, it mounts but doesn't let me access the drive, it says "You need to format the disk in drive D:\ before you can use it" (Windows). it's the exact same thing for both copies (which were made from two different original copies and confirmed to have the same SHA hashes of the originals when copied).

It doesn't make sense how it worked when they were copied, the SHA hashes being the same, and both of them don't work in the exact same way.

I do not want to use the two original copies again because if I have been hacked and someone is trying to damage my files/copies, then if they hadn't already been damaged when copied (which I can't know without using them), they would if I use them again.

Does anyone have an idea what reason could there be for this, and if a hack is involved, what would it be (and how do I protect myself from it if the originals haven't already been damaged)?

  • If someone wanted to hack you, they probably wouldn't intentionally damage and tip you off to their presence. They would silently monitor whats going on. Its not impossible that this is caused by a remote attacker, but what benefit would they gain by playing games with your hardware?
    – john doe
    Apr 21, 2021 at 14:11
  • They would copy the information and have the information to themselves, erasing my copies of the information. Do you have an idea of any other reason for this to have happened and how to fix it?
    – user255946
    Apr 21, 2021 at 15:47
  • Its probably just normal everyday buggy windows activity.
    – john doe
    Apr 21, 2021 at 19:34
  • So if the symptom is you cannot open the volume, maybe it's a very simply cause: Sometimes I enable "caps lock" by mistake or switch the keyboard layout unintended (e.g. from local DE to EN). Are you sure your keyboard works as intended? Also: Try to re-checksum your copies, comparing the results. You could use a different computer, or start some "clean" OS (assuming you prepared some) from USB or optical medium (like Tails, maybe).
    – U. Windl
    Jun 30 at 9:16
  • Another reason: VeraCrypt occasionally forgets its keyfiles, so maybe re-add them if you used some (or disable them if you did not). Likewise for PIM and algorithms: Depending on settings, you have to re-enter those (correctly).
    – U. Windl
    Jun 30 at 9:18


You must log in to answer this question.

Browse other questions tagged .