So I'm learning to run MITM attacks on my own WiFi network but I seem to be running into an issue. I'm following this tutorial.

The process is simple and I'm running the attack from my Ubuntu laptop. I first enable IP forwarding using echo > 1 /proc/sys/net/ipv4/ip_config. The command runs without an issue. Next up is setting up the ARP Spoof, for which I run these commands in separate terminals.

arpspoof -i eno1 -t -r
arpspoof -i eno1 -t is my Windows laptop, in this case, the target. is my router's default gateway.

The tutorial above says that I have to mention the attacking machine's (Ubuntu laptop's) IP in the -r flag, but that keeps giving me a couldn't arp for spoof host [Ubuntu machine's IP]. I Googled around and found that you have to mention the default gateway (the router's IP) there, so I did and the arpspoof command ran fine.

However, as soon as I run the arpspoof command, the target machine loses internet access and sometimes drops the WiFi connection altogether. Not to mention I am not able to capture any HTTP packets on Wireshark.

Can anyone point out what I'm doing wrong?

I've tried the solution pointed out in this answer, didn't work for me.

  • Just a thought, try setting net.ipv4.ip_forward to 1 in /etc/sysctl.conf and reload it using the command sysctl -p.
    – Jeroen
    Jun 27, 2021 at 5:46
  • No change. I still have the same issue.
    – YaddyVirus
    Jun 27, 2021 at 22:01
  • Have you tried it from an Ethernet connection instead of wireless yet?
    – Jeroen
    Jun 27, 2021 at 22:08
  • @Jeroen My Ubuntu machine is connected via ethernet and the Windows machine is connected via WiFi.
    – YaddyVirus
    Jun 28, 2021 at 7:37


You must log in to answer this question.

Browse other questions tagged .