0

I want to attach a valid ssl subdomain to my pfsense. I would check it (with warnings) via my the pfsense's IP 192.168.11.1 .

I used multiple tutorials to come up with the following:

  1. Bought a domain
  2. Set the domain's namespace to cloudflair
  3. Setup an cloud flair API key with dns zone edit rights and collected various cloudflair details.
  4. Created an A record with a subdomain pointing to my static external ip

In my pfsense, I

  1. Installed ACME
  2. Added two ACME keys (one for staging and another for production)
  3. Created a certificate successfully (both in staging and production)
  4. Set my pfsense to new certificate
  5. Added my subdomain to the additional hostnames

At this point of time it worked. I thought I had more to do since I didn't know how the browser was resolving to my pfsense's IP.

The next day, it stopped working with the Error 522. Its complaining with a Cloudflair view that states my Host is the problem. I can still access the pfsense via IP.

Did I miss anything? What reason did it stop working?

1 Answer 1

0

I created an A record on my local DNS server and pointed it to my IP. Bam, it worked again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.