1

On my Windows 10 machine, I run mitmproxy on localhost:8080. I've changed the system proxy setting to point to my local proxy server.

Apart from what I expect to see, I can also see the following HEAD requests:

enter image description here

Typically, the headers look like this:

enter image description here

It looks the same for every request, just the Host header changes.

What are these? I tried to google the most of them, but I'm unable to get any relevant results.

In mitmproxy in event log, I can see records related to these requests (these 4 lines are related to the first http://ewxfuvvehmlzvfd/ request):

127.0.0.1:55607: error establishing server connection: [Errno 11001] getaddrinfo failed
127.0.0.1:55607: client disconnect
127.0.0.1:55607: closing transports...
127.0.0.1:55607: transports closed!

I also tried to run:

> Get-Process -Id (Get-NetTCPConnection -LocalPort 55607).OwningProcess

with no useful result but Get-NetTCPConnection : No MSFT_NetTCPConnection objects found with property 'LocalPort' equal to '55607'...

4
  • 1
    Are you running Chrome?
    – schroeder
    Aug 30, 2021 at 13:55
  • I was running Brave, which is based on Chromium. Thank you for the link, that might be it.
    – pavelsaman
    Aug 30, 2021 at 14:01
  • I think it does. In that answer, there's also a link to serverfault.com/questions/235307/… which explains it as well, perhaps in more detail, so I understand why Chrome, and it seems Brave based on Chromium as well, does it. Thank you.
    – pavelsaman
    Aug 30, 2021 at 14:07
  • No problem. That's what we're here for
    – schroeder
    Aug 30, 2021 at 14:34

0

Browse other questions tagged .