I want to crack a specific hash password with JTR:


I put this hash in a txt file like this:

echo '48bb6e862e54f2a795ffc4e541caed4d' > hash.txt

and I run JTR in this way:

john hash.txt --format=md5crypt --wordlist=/Users/ludo/Documents/TryHackMe/Dizionari/rockyou.txt

The result of John is:

ludo@MinidiLudovico CrackTheHash % ls hash.txt 
ludo@MinidiLudovico CrackTheHash % john hash.txt --format=md5crypt --wordlist=/Users/ludo/Documents/TryHackMe/Dizionari/rockyou.txt        
No password hashes loaded (see FAQ) 
ludo@MinidiLudovico CrackTheHash %

I'm sure that the password is in the rockyou.txt file because it is easy, and I'm sure that the password was hashed in MD5.

  • And you looked up the FAQ and tried the things there? Like --show and adding a line break to the hash?
    – schroeder
    Dec 30, 2021 at 11:24
  • 2
    If you want to crack raw md5, shouldn't the format be raw-md5 instead of md5crypt? Dec 30, 2021 at 11:44
  • @schroeder that's all the output you get, apart from possibly a line saying that it's using UTF-8 for input encoding. Much as I like John, it's output is not very helpful when you're trying to work out this kind of issue.
    – Gh0stFish
    Dec 30, 2021 at 14:51
  • No password hashes loaded (see FAQ) is the full output? I seriously doubt that ... john tends to pump out quite a lot of text as it runs. If I am wrong, then you need to run it in a more verbose mode ...
    – schroeder
    Dec 30, 2021 at 16:03
  • I posted a couple things 4 hours ago and I'm still wondering if you've tried them. --show, in case the hash has already been cracked, and adding a line break to the hash file.
    – schroeder
    Dec 30, 2021 at 16:15

2 Answers 2


That's not the correct format for an md5crypt hash. They typically start with $1$ - you can see examples of the various md5crypt formats that John accepts in the source code. When John reads your input file (hash.txt), you're telling it to only look for hashes in the md5crypt format - so it ignores the line in the file because it's not formatted correctly.

Your hash is just plain MD5, so you need to use --format=raw-md5 instead of --format=md5crypt

  • If I put --format=raw-md5 the result is: Unknown ciphertext format name requested Dec 30, 2021 at 15:21
  • Also if I run 'john hash.txt', and I don't put the md5crypt format it gives me the same output. 'No password hashes loaded (see FAQ)' Dec 30, 2021 at 15:25
  • If your version of John doesn't support raw-md5 it must be a strange or broken build. Use the version on GitHub, or check what formats your version supports.
    – Gh0stFish
    Dec 30, 2021 at 15:36
  • You don't need to go to the source code to see the correct inputs for the hashes. They are in the documentation: openwall.info/wiki/john/hash-formats
    – schroeder
    Dec 30, 2021 at 16:05
  • @schroeder that page hasn't been updated since 2012, and is missing many of the currently supported formats (and also several variants of md5crypt, such as the $apr1$ or {smd5} formats).
    – Gh0stFish
    Dec 30, 2021 at 16:10

I don't know why but there is a sort of problem with John the Ripper, I uninstalled it with:

brew uninstall john 

And I install another version of it named john-jumbo.

brew install john-jumbo

Now it works perfectly.

Ps. --format=md5crypt doesn't work with my hash so I used --format=raw-md5.

  • Yes, this was in the FAQ. raw-md5 format is in the larger, more complete version of john, but it should have worked without specifying the format, too.
    – schroeder
    Jan 1, 2022 at 12:24
  • I still think you had oriiginally installed a strange version because it was behaving in a non-standard manner.
    – schroeder
    Jan 1, 2022 at 13:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .